Low disk space on /data partition when downloading binaries in Fleet Management
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Low disk space on /data partition when downloading binaries in Fleet Management

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Article ID: 423663

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Downloading product binaries via Fleet Management causes the /data partition to run out of space, resulting in download failure.

  • The vmware_vrlcm.log contains entries similar to:

    yyyy-mm-ddThh:mm:ss.###Z ERROR vrlcm[#####] [pool-##-thread-##] [c.v.v.l.d.c.t.DownloadFromBroadcomDepot]  -- Exception encountered when downloading the binary: No space left on device

  • Reviewing vmware_vrlcm.log confirms that the "Use%" column in the output of df command is 100% near the error occurrences:

    yyyy-mm-ddThh:mm:ss.###Z INFO vrlcm[#####] [http-nio-####-exec-#] [c.v.v.l.u.ShellExecutor]  -- Executing shell command: df -h --output=size,used,avail,pcent /data/
    yyyy-mm-ddThh:mm:ss.###Z INFO vrlcm[#####] [http-nio-####-exec-#] [c.v.v.l.u.ProcessUtil]  -- Execute df
    yyyy-mm-ddThh:mm:ss.###Z INFO vrlcm[#####] [http-nio-####-exec-#] [c.v.v.l.u.ShellExecutor]  -- Result: [Size  Used Avail Use%
     123G  123G     0 100%].

Environment

VCF Operations 9.0

VCF Fleet Manager 9.0

Cause

When downloading binaries via Fleet Management, the file is first downloaded to the /data partition and then extracted into a temporary directory within the same partition. Subsequently, the extracted files are placed in the productPatchRepo directory, also located on the /data partition.

As a result, the process temporarily consumes approximately three times the storage space of the original binary size. For large binaries like VCF Automation, this can lead to the exhaustion of the /data partition depending on the available free space prior to the download.

Note: Once the files are successfully placed in the productPatchRepo directory, the initial download file and the temporary files are automatically cleared.

Resolution

To resolve this issue, expand the /data partition or delete any unnecessary binaries to ensure that the available free space is at least three times the size of the binary being downloaded.

Note: As the extraction process consumes disk space equivalent to or exceeding the original file size, please ensure there is ample free space—exceeding three times the binary size—from the perspective of maintaining a safe buffer.

Expanding the /data partition: See "Extending Storage for Binaries" for details.

Removing unnecessary binaries:

  1. Select Fleet Management > Lifecycle > Binary Management and select the binary type.

  2. To remove a binary, check the downloaded component and click the trashcan icon.

Additional Information

Japanese KB: Fleet Management でバイナリをダウンロードする際に /data パーティションのディスク容量が不足する (424112)