Upgrading HCX to 4.11.3 fails with error stating WANOPT is no longer being supported
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Upgrading HCX to 4.11.3 fails with error stating WANOPT is no longer being supported

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Article ID: 423579

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

  • When attempting to upgrade to HCX 4.11.3, and WANOPT service is enabled on the compute profile or service mesh, an error stating that you cannot proceed with the upgrade until these are removed is encountered.  
  • Within a VMC environment the following screen is observed when this issue is experienced.

Environment

VMware HCX versions prior to 4.11.3

Cause

This is a known product limitation.  Details around WANOPT service being deprecated can be viewed in the 4.11.3 Release Notes.

 

Resolution

  • The WANOPT service must be removed from the compute profile and service mesh on both sides of the connection. 
    • Ensure that you no longer see the appliance deployed and then proceed with the upgrade. 
  • To ensure that the service is not enabled on the compute profile, click edit and then make sure this is not selected on the "Select Services" tab.
  • To ensure that the appliance is no longer deployed click on "View Appliances" on the service mesh.  The WANOPT appliance will not be present in the list of appliances. 
    • Alternatively, viewing the vCenter inventory and ensuring you do not see the appliance VM deployed there would confirm the same information.