vMotion does not work and "failed criteria code" is seen in log files
search cancel

vMotion does not work and "failed criteria code" is seen in log files

book

Article ID: 423502

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

A vMotion virtual machine migration operation fails or is unable to start between one or more hosts in the environment.

Upon examining the vobd.log file on the affected hosts, a message including the phrase "Failed criteria code" appears prior to the failed vMotion operations.

    • To confirm this condition, search /var/log/vobd.log or /var/run/log/vobd.log for the presence of this message.

Cause

A "failed criteria code" message indicates that a network card has reported to ESXi that a physical link disconnection or fault exists. For example, criteria code 128 indicates that the link media is disconnected. This code is not generated by ESXi, but reported by the network card via its driver. 

Refer to the knowledge base article Network adapter (vmnic) is down or fails with a Failed Criteria Code for additional information on this message.

vMotion operations are coordinated through vCenter on the management network and the VM data is subsequently sent through a VMkernel interface that is enabled for the vMotion service.

In many environments, vMotion data is set up to go through a dedicated network using separate network cards and uplinks. As a result, a vMotion can appear to start and then fail as a result of issues on the vMotion interface, uplink or network, even as management and workload functions remain unaffected.

Resolution

Identify the vmnic associated with the "Failed criteria code" message along with the corresponding physical network interface and uplink.

Consult the article Network adapter (vmnic) is down or fails with a Failed Criteria Code for the meaning of the code.

Proceed to validate the functionality of the network interface, uplink and network.

  • Check the upstream switch and see if a physical LED or a virtual indicator on a management web page indicates that the switch ports connected to the host are active
  • Check the switch logs for unexpected disconnections or switch restart events
  • Examine the connectors and modules on the connection and reseat them if necessary
  • Contact your network card vendor or OEM for further assistance with firmware and drivers