Tanzu Hub features appear disabled (greyed out) in the GUI.
search cancel

Tanzu Hub features appear disabled (greyed out) in the GUI.

book

Article ID: 423423

calendar_today

Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

After deploying the Tanzu Hub tile and the Platform Services tile on the Tanzu Platform, users are unable to click on options such as Orgs or Applications etc.

Environment

Tanzu Hub v10.3.x

Platform Services v10.3.x

TPCF/Elastic Application Runtime v10.x

Cause

The license key has not been applied in the Tanzu Hub portal.

Resolution

The license key is the same for both Tanzu Hub and TPCF / Elastic Application Runtime. Therefore, the customer can retrieve the license key from the TPCF / Elastic Application Runtime tile, configured under the License section.

Now, open the Tanzu Hub GUI and navigate to Administration → License.

Enter the key in the “Enter license key” field, the hub will validate it. In the screenshot above, the license key has been blacked out after being entered.

Once the process is complete, refresh the portal in your browser. All options will then appear on the left side of the Tanzu Hub window.