Intermittent connection between Agent and Scalability Server when using TCP
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Intermittent connection between Agent and Scalability Server when using TCP

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Article ID: 423310

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

CAM can be set to use TCP 4105 port instead of default 4104 UDP, procedure explained here:

How do I configure CAM to use TCP from the command line?

When this change is done, Port Multiplexer Service (CSAM PMUX) is used to connect both endpoints.

If there is a connection problem between these 2 endpoints, it’s possible that CSAM port is having a problem.

Environment

Client Automation 14.5 and above

Cause

CSAM PMUX service uses port 7163 and if there is any block/filter of it between the 2 involved machines, a connection problem may happen.

A simple way to check this is to run ‘camstat -a’ command on any of the involved machines, and check the state of the connection of the target machine:

Host                  proto state  port  Qlen  m/sent  m/recv  retry  disc  RTO

--------------------- ----- ----- ----- ----- ------- ------- ------ ----- ----

11.22.33.44            tcp   CWT  4105     1     421     431     39    19   60

In this case, the state “CWT” corresponds to “Connection Wait”, which means the local machine sent a connection request but the ACK has not yet received, this may mean an actual blocking/filtering of port 7163.

Resolution

There are several ways to check ports availability between 2 endpoint, but the following Powershell command can be used:

Test-NetConnection -ComputerName 11.22.33.44 -Port 7163

The result will show the local and remote address, the port being tested, the interface used and the result.