SD Jobs not working. Encrypted/Compressed delivery failure
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SD Jobs not working. Encrypted/Compressed delivery failure

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Article ID: 423261

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Sending of SD Jobs to Agents is not work. The job remain in waiting state (Job Execution Staged) and fails with timeout error.

In TRC_USD_SDSERVER*.log we could see this error :

161225-10:27:13.6495236L|008864|00002788|SDServer  |CFSMCAPI|CFSMCAPI|000000|WARNING| SmiEndPoint::handleMspiMessage : Encrypted/Compressed delivery failure. Message will not be processed

Environment

Client Automation - All Versions

Cause

This problem could occur with following conditions :

  • Scalability Server is in version 14.5 or 14.6 and Agent in version 14.0 SP3 or earlier version
  • Following configuration is applied on the Scalability Server

    DSM/Common Components/Security/FIPS 140 Settings = Only FIPS 140 approved security functions are allowed

 

This problem is caused by new version of CAPKI included in 14.5.

See : New Features and Enhancements - 14.5

Resolution

If there are old installed Agent version (14.0 SP3 or older), change the configuration policy applied on the scalablity servers like this :
 
DSM/Common Components/Security/FIPS 140 Settings = FIPS 140 approved security functions are preferred
 
When all Agents are in version 14.5 or 14.6, this settings could be set again to Only FIPS 140 approved security functions are allowed