Error generated when executing an api reallocate call
search cancel

Error generated when executing an api reallocate call

book

Article ID: 423160

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

After attempting to execute the following API call:

POST https://FQDN/api/v1/logical-routers/<GUID>?action=reallocate

The following error is returned:

{

 

    "module_name": "common-services",

 

    "error_message": "General error has occurred.",

 

    "details": "Cannot invoke \"com.vmware.nsx.management.edge.lrouter.ports.model.LRPortECResourceAllocation.getRevision()\" because \"oldAllocation\" is null",

 

    "error_code": 100

 

}




Environment

VMware NSX

Cause

This error is the result of not providing the correct GUID of the T1.

Resolution

Please use the following methods to acquire the GUID if the T1 router in question:

Using the NSX Manager UI (GUI)

     Login: Access your NSX Manager.

     Navigate: Go to Routing > Tier-1 Gateways

     Select Router: Click on the specific T1 router you're interested in.

     View Details: The UUID (GUID) is often displayed in the router's overview or details section, or you can check its associated interfaces and ports.

Or


Using NSX Command Line Interface (NSXCLI)

     SSH to NSX Manager:

     ssh admin@<nsx-manager-ip>
     get logical-routers | grep "Tier-1 Router Name"

Additional Information

Relater KB:

Tier-1 gateway not getting assigned as per failure domain preference