vSAN Cache Disk is in Absent state under Disk management
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vSAN Cache Disk is in Absent state under Disk management

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Article ID: 423147

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Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN cache disk can be observed as absent under vSAN Cluster -> configure -> disk group -> select the specific ESXi host -> view disks.

 

Running the command vdq -Hi will show the impacted disk's UUIDs instead of naa id.

Mappings:
   DiskMapping[0]:
           SSD:  ########-####-####-####-############    <-- The disk's UUID will be observed instead of showing the NAA ID
            MD:  naa.################
            MD:  naa.################
            MD:  naa.################
            MD:  naa.################

 

Environment

VMware vSAN 7

VMware vSAN 8

Cause

If vSAN has acknowledged the device as faulty, it can be shown as Absent in the disk group.

This issue occurs due to one or all of these reasons:

 

  • A physical disk failure.
  • Medium error.
  • The physical disk has been removed from server, before removing the disk from vSAN disk group.

 

Resolution

  • Put the ESXi host in Maintenance mode with Ensure Accessibility.
  • Remove the disk group from vSAN disk group (vSAN cluster- > Configure -> Disk Management -> Select the ESXi host -> View Disks -> click on the 3 dots on the disk group and remove it.
  • Engage your hardware vendor and replace the faulty disk.
  • Go to vSAN Cluster -> configure -> disk group -> select the ESXi host -> view disks -> Create Disk Group with newly added cache disk.

 

Note:  Since the cache disk is faulty, the whole disk group need to remove and re-create with newly added cache disk. 

 

Follow the KB article Managing and Configuring a vSAN disk group using esxcli commands  on how to create the disk group using ESXi host CLI.