vSAN Cache Disk is in Absent state under Disk management
search cancel

vSAN Cache Disk is in Absent state under Disk management

book

Article ID: 423147

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN cache disk is showing absent for one of the ESXi host

Environment

vSAN 8

vSAN 7

Cause

vSAN disk management shows the Cache disk as faulty.

Resolution

Replace the physical disk and recreate the disk group.

This will make the disk group healthy.

Follow the KB - https://knowledge.broadcom.com/external/article?articleNumber=315532   on how to create the disk group using the CLI method.

 

Before following the below action plan, we need check the ESXi host logs to check for the failure reported on the faulty drive. If vSAN has acknowledged the device as faulty or marked it as offline, we can proceed with the below steps.

To remove and recreate a disk group using esxcli commands:
 
Note: These steps can be data-destructive if not followed carefully.
  1. Log in to the ESXi host that owns the disk group as the root user using SSH.
  2. Run one of these commands to put the host in Maintenance mode. There are 3 options:

    Note: VMware recommends using the ensureObjectAccessibility option. Failure to use this ensureObjectAccessibility mode or evacuateAllData mode may result in data loss.
     
    • Recommended:
      • Ensure accessibility of data:
        esxcli system maintenanceMode set --enable true -m ensureObjectAccessibility
      • Evacuate data:
        esxcli system maintenanceMode set --enable true -m evacuateAllData
         
    • Not recommended:
      • Unless recommended by VMware Support or in addressing a failed disk scenario. Ensure accessibility or full data migration cannot be used of a failed disk.
      • Don't evacuate data:
        esxcli system maintenanceMode set --enable true -m noAction
         
  3. Record the cache and capacity disk UUIDs in the existing group by running this command:
    esxcli vsan storage list

    Example output of a capacity tier device:
    naa.123456XXXXXXXXXXX:
    Device: naa.123456XXXXXXXXXXX
    Display Name: naa.123456XXXXXXXXXXX
    Is SSD: true
    VSAN UUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx8fa3
    VSAN Disk Group UUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxd008e
    VSAN Disk Group Name: naa.50000XXXXX1245
    Used by this host: true
    In CMMDS: true
    On-disk format version: 5
    Deduplication: true
    Compression: true
    Checksum: 5356031598619392290
    Checksum OK: true
    Is Capacity Tier: true
    Encryption: false
    DiskKeyLoaded: false

    Note: For a cache disk:
    • the VSAN UUID and VSAN Disk Group UUID fields will match
    • Output will report: Is Capacity Tier: false
       
  4. Then remove the disk group
    esxcli vsan storage remove -u <VSAN Disk Group UUID>

    Note: Always double check the disk group UUID with the command:
    esxcli vsan storage list

  5. If you have replaced physical disks, see the Additional Information section.
     
  6. Create the disk group, using this command:
    esxcli vsan storage add -s naa.xxxxxx -d naa.xxxxxxx -d naa.xxxxxxxxxx -d naa.xxxxxxxxxxxx


    Where naa.xxxxxx is the NAA ID of the disk device and the disk devices are identified as per these options:
     
    • -s indicates a cache disk.
    • -d indicates a capacity disk.
       
  7. Run the esxcli vsan storage list command to see the new disk group and verify that all disks are reporting True in the "In CMMDS:" field output.

Additional Information

https://knowledge.broadcom.com/external/article?articleNumber=315532