We added a new DC to NetOps but it is showing unknown polling status and IP address
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We added a new DC to NetOps but it is showing unknown polling status and IP address

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Article ID: 423132

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

After adding a new DC, in the portal data collector view, we see that it has an ip address of loopback (127.0.1.1)

And the polling status is unknown.

Environment

 DX NetOps :: All Supported Versions

Cause

 The hosts file on the DC host is misconfigured

Example of the bad hosts file:

……………

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4

::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

127.0.1.1 <longname> <shortname>

Resolution

 Fix the host file.

Remove the 127.0.1.1.

 

Example of a good hosts file:

 

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4

::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

<real IP> <longname> <shortname>

 

Stop the dcmd and activemq services.

cd (installdir)/scripts

./dcmd clean

 

Start dcmd

Additional Information

You may also need to recycle the da services and run a clean there as well

 

Stop the dadaemon and activemq

cd (installdir)/scripts

./dcmd clean

Start dadaemon