VMs' guest OS applications are throwing error: "wrapper process has not received any cpu time"
search cancel

VMs' guest OS applications are throwing error: "wrapper process has not received any cpu time"

book

Article ID: 423106

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This error message is a java application error message.

When an application throws the error "wrapper process has not received any cpu time", it means that the application's service manager (called "wrapper") is failing to get access to the processor. This can happen due to resource problems on the VM and/or HOST. If the host has sufficient capacity, the VM's hardware version should be verified against the version of ESXI the host is running.

When viewing the Summary tab for the VM in vSphere Client (the vCenter web GUI), vmware tools' status regularly changes from "Running" to "Not Running". These status changes coincide with messages in /var/log/hostd.log of the VMs' hosts that note change in heartbeat status (changes between grey, green, yellow, and red):

2025-12-24T23:59:59.999Z Db(###) Hostd[#######]: [Originator@#### sub=Vmsvc.vm:/vmfs/volumes/<someDatastore>/<yourVMName>/<yourVMName>.vmx] Updating current heartbeatStatus: gray -> green

2025-12-24T23:59:59.999Z Db(###) Hostd[#######]: [Originator@#### sub=Vmsvc.vm:/vmfs/volumes/<someDatastore>/<yourVMName>/<yourVMName>.vmx] Updating current heartbeatStatus: red -> yellow

2025-12-24T23:59:59.999Z Db(###) Hostd[#######]: [Originator@#### sub=Vmsvc.vm:/vmfs/volumes/<someDatastore>/<yourVMName>/<yourVMName>.vmx] Updating current heartbeatStatus: yellow -> gray

 

Environment

vSphere 8.x

Cause

Wrapper errors in VM applications can throw if the ESXi host was recenlty upgraded to 8.x from 7.x, and the VM's were not changed at all. In looking in the /var/log/hostd.log file of the host running afflicted VM's, there may be messages like the following:

2025-12-17T12:34:50.123Z In(###) Hostd(#######): [Originator@#### sub-Vmsvc.vm:/vmfs/volumes/<someDatastore>/<yourVMName>/<yourVMName>.vmx] Upgrade is required for virtual machine, version: ##

Resolution

  1. Upgrade the afflicted VM's hardware version. Refer to "Upgrading a virtual machine to the latest hardware version (multiple versions)".
  2. Verify the hostd.log messages regarding heartbeat status and upgrades are no longer appearing in the /var/log/hostd.log file on the host of an afflicted VM.
  3. Verify within the VM guest OS that the java application's wrapper error is no longer being thrown.