IP addresses not getting released after a failed attempt to create a VPC subnet 
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IP addresses not getting released after a failed attempt to create a VPC subnet 

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Article ID: 423064

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Initially, subnet creation failed with some type of validation error, such as an invalid DHCP relay path.
  • The failed VPC subnet had been configured to use the entire IP block.
  • Every attempt to create a new VPC subnet from the IP block fails.
  • Attempting to create the new VPC subnet via API fails with a "spare capacity" error: 
    https://<nsx_manager_fqdn>/policy/api/v1/orgs/default/projects/<project_name>/vpcs/<vpc_name>/subnets/<subnet_name>



  • Log messages similar to the below will be found within NSX Manager var/log/syslog file: 

    2025-12-08T19:21:55.957Z ERROR http-nio-127.0.0.1-7440-exec-27 VpcIpamTransactionHelper 6188 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM409" level="ERROR" reqId="e606####-5456-####-b2fa-####2c7c3453" subcomp="manager" username="#########@#####.###.gov"] Caught Exception after calling runnable.
    java.util.concurrent.CancellationException: null
            at java.util.concurrent.CompletableFuture.cancel(Unknown Source) ~[?:?]
            at com.vmware.nsx.management.policy.abstractions.utils.VpcIpamTransactionHelper.ipamDataPolling(VpcIpamTransactionHelper.java:47) ~[?:?]
            at com.vmware.nsx.management.policy.abstractions.realization.adapters.VpcSubnetAdapterImpl.cleanupIpamDataOutsideTxn(VpcSubnetAdapterImpl.java:693) ~[?:?]
            at com.vmware.nsx.management.policy.abstractions.realization.adapters.VpcSubnetAdapterImpl.handleCreateOrUpdate(VpcSubnetAdapterImpl.java:150) ~[?:?]

Environment

VMware NSX 4.2.x earlier than 4.2.3.3

 

Cause

There is a bug in NSX 4.2.x that causes IP address management (IPAM) cleanup to not proceed correctly if a prior subnet creation had failed. 

Resolution

  • This is a known issue affecting VMware NSX. There is currently no resolution, but one will be included in an NSX release in the near future.
  • If you find yourself in this situation, please:
    • Open a support request with Broadcom support, mentioning this KB in the support request description.  Refer to Creating and Managing Broadcom Support Cases for instructions on how to open a support request.
    • Gather an NSX Manager log bundle and upload them to us through the support portal.  Refer to Collect Support Bundles for instructions on how to gather the NSX support bundle.