ESXi host shows disconnected on the NSX manager. Error message: The service nsx-cfgagent has been unresponsive for 10 seconds
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ESXi host shows disconnected on the NSX manager. Error message: The service nsx-cfgagent has been unresponsive for 10 seconds

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Article ID: 423025

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The ESXi host appears as "Disconnected" in the NSX Manager interface, although the host itself is operating normally with no observable issues

  • The following error is observed on the NSX UI:

 

In the NSX manager logs, following entries will be seen in the /var/log/syslog:

less /var/log/syslog | grep -i " Waiting for fabric-node installation failure to be fixed: Failed to install software on host. Time out waiting for host to join NSX Manager"

  • Timestamp:hostname NSX 520096 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] FN #####-8a60-3b3495780253 installation status = Waiting for fabric-node installation failure to be fixed: Failed to install software on host. Time out waiting for host to join NSX Manager., statelessHost = false, forceSync = false
  • Timestamp:hostname NSX 520096 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Paused configuring TransportNode TransportNode/#####-8a60-3b3495780253. Waiting for fabric-node installation failure to be fixed: Failed to install software on host. Time out waiting for host to join NSX Manager.
  • Timestamp:hostname NSX 520096 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] FN #####-8a60-3b3495780253 installation status = Waiting for fabric-node installation failure to be fixed: Failed to install software on host. Time out waiting for host to join NSX Manager., statelessHost = false, forceSync = false

 

Environment

VMware NSX

Cause

The NSX VIBs are not correctly installed on the ESXi host.

Resolution

Workaround:

Place the host in maintenance mode. Remove the host from the cluster and re-add it. This would trigger the deletion of NSX (vibs) and reinstallation of the same.

If the above doesn't help, kindly open a ticket with Broadcom Support Team via  Broadcom support portal