IAM not Starting: ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: Failed to start server in (production) mode
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IAM not Starting: ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: Failed to start server in (production) mode

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Article ID: 422986

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Updated On:

Products

Service Virtualization

Issue/Introduction

IAM will not start showing these ERROR messages in the server.log file:

2025-12-18 15:32:22,735 ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: Failed to start server in (production) mode
2025-12-18 15:32:22,736 ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: Unable to start HTTP server
2025-12-18 15:32:22,736 ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) ERROR: java.io.EOFException
2025-12-18 15:32:22,737 ERROR [org.keycloak.quarkus.runtime.cli.ExecutionExceptionHandler] (main) For more details run the same command passing the '--verbose' option. Also you can use '--help' to see the details about the usage of the particular command.

Environment

DevTest 10.8.4, but can happen in any supported DevTest release.

Cause

The IAM_HOME\certs\iam-truststore.ks file was corrupted and had 0 bytes.

Resolution

Needed to restore the iam-truststore.ks file from a backup and restart IAM.

Additional Information

Do not know how the iam-truststore.ks file had 0 byes.