Rotating Service Account Password Does Not Update 'Last Modified' Field
search cancel

Rotating Service Account Password Does Not Update 'Last Modified' Field

book

Article ID: 422949

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

When rotating passwords in SDDC Manager's Password Manager for service accounts, the 'Last Modified' date is not updated. 

Environment

SDDC Manager 5.x

SDDC Manager 9.0 

Cause

SDDC Manager stores passwords for its own service and break-glass accounts (e.g., root, admin, etc.), but not for the external components it manages, such as NSX and VxRail. Because the password value is not stored, the back-end secure credential service perceives the old and new passwords as identical (null). This prevents the "last modified time" from updating, resulting in a cosmetic issue where the last modified date remains unchanged, even though the password rotation is successful.

Resolution

This issue is planned to be fixed in a future release of 5.2.x and 9.x