Aria Automation: Incorrect Storage resource numbers calculated for project / cloud zone quotas when deployments are interrupted
search cancel

Aria Automation: Incorrect Storage resource numbers calculated for project / cloud zone quotas when deployments are interrupted

book

Article ID: 422923

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Resource totals for Storage, CPU, Memory, Instances remain incorrect (too high) for more than 24 hours
  • Figures are not fixed using the recalculation package in KB 326134 or the script in KB 407452 
  • The additional resources can not be explained by migration/reconciliation as in KB 396325 
  • Deployments in Automation have been interrupted/cancelled in the past 2 weeks
  • Additional resources can be seen in the following DB table, which account for the extra resource quantities:
    • SELECT resource_count, cpu_reservation, memory_reservation, storage_reservation, to_char(to_timestamp(creation_time_micros / 1000000), 'DDMMYYYY') AS creation_date, to_char(to_timestamp(expiration_time_micros / 1000000), 'DDMMYYYY') AS expiration_date from unconfirmed_reservation;

Environment

VMware Aria Automation 8.x

Cause

Resources exist in the unconfirmed_reservation table which also contribute to the totals.
This table is for in-progress deployments: it is meant to reserve resources into the totals from the start of deployment, so that quotas can't be exceeded by simultaneous deployments.

If the deployments are interrupted, then the resources remain here until expiry which can take 2 weeks.

Resolution

If you face this issue, please contact Broadcom Support, referencing this article ID #422923