Remote logging not configured alarm appears on NSX Manager node after upgrade
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Remote logging not configured alarm appears on NSX Manager node after upgrade

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Article ID: 422914

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Updated On:

Products

VMware NSX

Issue/Introduction

  • After upgrading VMware NSX to version 4.2.1.3 or later, an alarm stating "Remote Logging not configured" is triggered on one or more NSX Manager nodes.
  • This issue may appear on a single node while others in the cluster remain in a normal state or may appear for all three managers.

Environment

VMware NSX 4.1.2 and later (Alarm introduced in 4.1.2)

Cause

This alarm is triggered because the specified NSX nodes do not have a syslog server configured. Beginning with NSX 4.1.2, the system explicitly checks for active syslog configurations on manager nodes and raises this alarm.

Resolution

To resolve this issue, you must configure a syslog server for the affected node. There are two methods to achieve this detailed below:

  • Method 1: Configure via Central Node Profile (UI) for all Edges and Managers within the environment 

    You can apply a syslog configuration using a central node profile within the NSX Manager UI.
    For instructions on adding syslog servers via the UI, please refer to the following product documentation - Admin Guide - Add Syslog Servers for NSX Nodes

    Important: Applying a central profile will overwrite ALL existing syslog configurations by default for Edge and Manager nodes within the environment
    , unless the nodes have their central node profile disabled (via cli command  set node central-config disabled). Ensure you review existing configurations before applying this change.
    Note: Central Node Profile may already be configured but has been disabled in a single node.

  • Method 2: Configure via Command Line Interface (CLI) on a per node basis.

    You can configure remote logging directly on the individual manager or edge node using the CLI.
    For detailed steps on identifying and configuring the facility code, protocol, and port, please refer to the following product documentation - Admin Guide - Configure Remote Logging

Additional Information

For further context regarding this specific alarm, refer to the following Knowledge Base article: