SDDC Manager DVPG Configuration Drift fails with error "VM Migration failed"
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SDDC Manager DVPG Configuration Drift fails with error "VM Migration failed"

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Article ID: 422911

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • SDDC manager UI reports the below error message:

Message: VM Migration failed
Remediation Message:
Reference Token: QORAT2
Cause: NotFound (com.vmware.vapi.std.errors.not_found) => { messages = [], data = struct => {error_message=Transport node b4f#####-####-####-####-##########092 not found, httpStatus=NOT_FOUND, error_code=29501,module_name=HeatMap}, errorType=NOT_FOUND}

 

  • /var/log/vmware/vcf/domainmanager/domainmanager.log

YYYY-MM-DDTHH:MM:SS.418+0000 DEBUG [vcf_dm, 6924a#######################e9a9, 2del] [c.v.v.c.o.s. ConfigreconcilerOrchServiceImpl, dm-exec-19] 44 and drifts [217#####-####-####-####-#########0a7]:{"id": "086#####-####-####-####-###########b44","name":"Configuration Updates", "status": "FAILED", "reconciliationSubTasks":[{"driftId": "217#####-####-####-####-##########0a7", "driftName":"Creates a Distributed Virtual Port Group to enable traffic isolation between management VMs and ESXi hosts","driftDescription":"Creates a Distributed Virtual Port Group to enable traffic isolation between management VMs and ESXi hosts","status": "FAILED", "creationTimestamp": "YYYY-MM-DDTHH:MM:SS", "completionTimestamp": "YYYY-MM-DDTHH:MM:SS:849Z", "errors": [{"errorCode": "VM MIGRATION FAILED", "context": {"orchestrator. error. retriable": "false"), "message": "VM Migration failed", "cause": [{"type": "com. vmware. vapi. std. errors. NotFound", "message": "NotFound (com.vmwaware.vapi.std.errors.not_found) data\u003d struct \u003d\u003e {error_message\u003dTransport node b4f#####-####-####-####-##########092 not found, httpStatus errorType \u003d NOT_FOUND\n)"} ], "referenceToken":"QORAT2")]}1}

Environment

VMware Cloud Foundation 5.x

Cause

  • A mismatched NSX Edge Node ID within the NSX/SDDC configuration led to the failure of migration operations when updates were applied to that node.
  • Note that re-deployment of an NSX Edge Node can introduce inconsistencies into the overall NSX/SDDC configuration.

Resolution

This resolution requires manual changes to the SDDC Manager database. Please contact Broadcom Support for assistance.