CSI syncer continuously logs "Already registered as a CNS volume"
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CSI syncer continuously logs "Already registered as a CNS volume"

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Article ID: 422872

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Updated On:

Products

VMware Tanzu Kubernetes Grid Integrated Edition

Issue/Introduction

The csi-syncer process is continuously logging the below error for some Persistent Volumes. This can lead to increased memory consumption for csi-syncer process.

  "level": "info",
  "time": "2025-12-05T09:16:52.207232446Z",
  "caller": "volume/util.go:373",
  "msg": "Extract vimfault type: types.CnsAlreadyRegisteredFault  vimFault: {CnsFault:{BaseMethodFault:<nil> Reason:Already registered as a CNS volume} VolumeId:{DynamicData:{} Id:########-b45e-415f-b301-############}} Fault: &{DynamicData:{} Fault:{CnsFault:{BaseMethodFault:<nil> Reason:Already registered as a CNS volume} VolumeId:{DynamicData:{} Id:########-b45e-415f-b301-############}} LocalizedMessage:Volume is already registered with ID ########-b45e-415f-b301-############. Error message: Already registered as a CNS volume} from resp: &{DynamicData:{} VolumeId:{DynamicData:{} Id:} Fault:0xc079c0fac0}",

The PV is attached and mounted to the Worker node and volumeattachment resource is reporting attached status.

No other issues reported with the PV apart from the above log message.

Environment

TKGi with CSI PVs provisioned.

Cause

There is a synchronisation issues between the datastore and VCDB.

Resolution

Please refer to Resolution section in KB CNS volume have disappeared from the CNS database to resync the datastore in the database.

If the issue persists after the resync, please contact Broadcom Support for further assistance.