vSAN File server NFS mount failure
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vSAN File server NFS mount failure

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Article ID: 422865

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Updated On:

Products

VMware vSAN 8.x

Issue/Introduction

  • The NFS clients failed to mount one or more NFS shares after ESXi rebooting in the vSAN cluster.
  • It's found the service status was unhealthy in FSVM Ganesha/NFS Logs.

In the FSVM logs,"/scratch/log/vdfs_support/containers/fs_vm_logs/fsvm_logs/containers/<ContainerName>/ganesha/ganesha.log"

YYYY-MM-DDTHH:MM:SSZ : epoch ######## : <Hostname> : ganesha.nfsd-104[none] [dbus_heartbeat] 1009 :nfs_health :DBUS :Health status is unhealthy. enq new: 26875, old: 26869; deq new: 26869, old: 26869
YYYY-MM-DDTHH:MM:SSZ : epoch ######## : <Hostname> : ganesha.nfsd-104[none] [dbus_heartbeat] 1009 :nfs_health :DBUS :Health status is unhealthy. enq new: 29604, old: 29602; deq new: 29602, old: 29602

Environment

vSAN 8.0

Cause

The NFS service "ganesha.nfsd" was unhealthy.

Resolution

There are two solution.

  • Restart the FSVM

Place the affected ESXi host (where the FSVM is running) into maintenance mode using the "Ensure Accessibility".
The affected FSVM will be power off.
Then Exit Maintenance Mode, the FSVM will be power on.

  • Recreate the FSVM on the host

Place the host into maintenance mode.
Right-click the affected FSVM and select "Delete from Disk" to remove the VM completely.
Take the host out of maintenance mode, the FSVM will be re-created automatically.

Additional Information

vSAN -- File Services -- File Service VM (= FSVM) reports: "Virtual Machine Consolidation Needed Status"
https://knowledge.broadcom.com/external/article/317898/