VCF Operations root account showing disconnected in VCF Operations Manager UI
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VCF Operations root account showing disconnected in VCF Operations Manager UI

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Article ID: 422725

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Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation VCF Operations

Issue/Introduction

When viewing the Fleet Manager > Password > VCF Management section in the VMware Cloud Foundation (VCF) Operations Manager UI, the root account displays a Disconnected status.

This issue may affect one or more VCF Operations appliances, including Cloud Proxy nodes.

Environment

VMware Cloud Foundation 9.x

VMware vSphere Foundation 9.x

Cause

This issue occurs when the root password for the VCF Operations appliance operating system has expired. When the password expires, the Operations Manager can no longer authenticate with the node to monitor its status, resulting in the "Disconnected" state.

Resolution

To resolve this issue, you must reset the expired password on the operating system of the affected nodes and then remediate the password within the Fleet Manager.

Steps to follow:

1. Prepare the Cluster

    1. Log in to the VCF Operations Manager Admin UI (typically https://<FQDN>/admin).

    2. Take the cluster Offline.

    3. Once the cluster is offline, take a Snapshot of all affected virtual machines (VCF Operations nodes and/or Cloud Proxy).

    4. Ensure Quiesce guest file system and Snapshot the virtual machine's memory are unchecked.

2. Perform the following steps for each appliance showing the disconnected status one by one:

    1. Open the Web Console or Remote Console for the appliance via vCenter Server managing the Appliance.

    2. Log in using the root account and the current password.

    3. The system will prompt that the password has expired.

    4. Enter the current password again.

    5. Enter a new password and confirm it.

      Note: Avoid using special characters like ( !, #, %, &, |, <, >, ;, ', or " )in the new password to prevent potential parsing issues.

    6. Flush the new data to disk by running the following command: 
      sync

3. Bring Cluster Online

    1. Return to the VCF Operations Manager Admin UI.

    2. Bring the cluster back Online.

    3. Wait for the process to complete and ensure the cluster status is healthy.

4. Remediate Password in Fleet Manager

    1. Log in to the VCF Operations Manager UI.

    2. Navigate to Fleet Manager > Password > VCF Management section.

    3. Select one of the accounts currently showing Disconnected.

    4. Click Remediate.

    5. Enter the new password created in Step 2.

    6. Once the remediation is successful for the first node, repeat this step for any remaining disconnected accounts.

Additional Information

Since the system performs password validation checks periodically, it may take anywhere from 1 to 24 hours for the account status to visibly update to Active (green) in the UI after a successful remediation.