Unable to export Firewall Logs for a large number of logs in the VMware Cloud Director as it never completes
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Unable to export Firewall Logs for a large number of logs in the VMware Cloud Director as it never completes

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Article ID: 422700

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When attempting to export firewall logs as CSV from the VMware Cloud Director(VCD) UI, the export process does not complete successfully.
  • The loading bar remains active for an extended period but the export of logs never completes even when the selected date range is as short as 30 minutes.

Environment

VMware Cloud Director 10.6.1.1

Cause

This is an issue with the current versions of VCD.
The way it works is, VCD UI sends continuous calls to backend to fetch all data based on how many pages of data are there. For example in the first call if backend returns total-page-count as 100 then UI will do 99 more calls. but unfortunately if the data to be exported is too high, the call to fetch data keeps on going, eventually VCD UI freezes. 

Resolution

As a workaround you can use the filter like this for getting any CSV for a specific time period:  

https://VCLOUD_ADDRESS/cloudapi/1.0.0/vdcGroups/urn:vcloud:vdcGroup:GROUP_ID/dfwPolicies/default/logs?page=1&pageSize=128&filterEncoded=true&filter=timestamp=gt=2025-09-08T07:00:00.000Z;timestamp=lt=yyyy-mm-ddThh:mm:ss.000Z;action==Drop;direction==IN;protocol==tcp&links=true

Or you can try downloading the CSV using VCD API Explorer:
You can go to VCD UI-> API Explorer -> dfwPolicy -> GET: /1.0.0/vdcGroups/{vdcGroupId}/dfwPolicies/{policyId}/logs

For more information you can refer the document for API endpoint: https://developer.broadcom.com/xapis/vmware-cloud-director-openapi/latest/cloudapi/1.0.0/vdcGroups/vdcGroupId/dfwPolicies/policyId/logs/get/