VMware Aria Operations for Logs Alert ’vCenter collection failed‘
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VMware Aria Operations for Logs Alert ’vCenter collection failed‘

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Article ID: 422636

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Updated On:

Products

VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

  • Following alerts were triggered in VMware Aria Operations for Logs:

    vCenter collection failed
    vCenter auto-configuration failed
    vCenter update inventory failed

  • Script 'lsdoctor -t' was executed on the affected vCenter Server. For details, refer to the KB article Using the 'lsdoctor' Tool
  • Aria Operations for log /storage/var/loginsight/runtime.log reports the following error:

     ["Thread-XXXX"/XXXX ERROR] [com.vmware.loginsight.scheduled.metrics.ScheduledMetricCalculationS
    ervice] [Failed to process metrics: ]
    java.lang.RuntimeException: java.lang.RuntimeException: javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.pr
    ovider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
            at com.vmware.ops.api.client.internal.RestClientProxy.acquireToken(RestClientProxy.java:302) ~[vcops-suiteapi-client-1.12.jar:?
    ]
            at com.vmware.ops.api.client.internal.RestClientProxy.acquireTokenIfNecessary(RestClientProxy.java:277) ~[vcops-suiteapi-client
    -1.12.jar:?]
            at com.vmware.ops.api.client.internal.RestClientProxy.invoke(RestClientProxy.java:253) ~[vcops-suiteapi-client-1.12.jar:?]
            at com.vmware.ops.api.client.internal.DefaultClient$InvocationHandlerWrapper.invoke(DefaultClient.java:308) ~[vcops-suiteapi-cl
    ient-1.12.jar:?]

Environment

VMware Aria Operations for Logs

Cause

lsdoctor script corrects SSL trust mismatch issues in the lookup service.  The lookup service registrations may have an SSL trust value that doesn’t match the MACHINE_SSL_CERT on port 443 of the node.
Re-register any external solutions that were previously pointed to the affected node(s) (SRM, vSphere Replication, NSX-V, etc.)

Resolution

1. Log in to the Aria Operations for Logs web user interface with administrator credentials.

2. Navigate to the Administration section, and under Integrations, select vSphere.
    On the vSphere Integration page, verify the vCenter Server's IP address or FQDN.

3. Edit the configuration and re-enter the credentials for the vCenter Single Sign-On user with appropriate permissions.
    Click Test Connection to verify connectivity and accept any new SSL certificates if prompted.

4. Save the configuration to re-establish the connection.