vCenter Server patching fails with error "There is not enough space on the disk(s)" despite sufficient free space
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vCenter Server patching fails with error "There is not enough space on the disk(s)" despite sufficient free space

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Article ID: 422619

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to patch VMware vCenter Server, the operation fails with the following error message displayed in the dialog.
There is not enough space on the disk(s). Increase disk space and try again.

However, there appears to be sufficient free space available when checking the disk usage.

Environment

vCenter Server 7.0

vCenter Server 8.0

Cause

Discrepancies exists between downloaded rpms and available updates. You can find the staging error message in /var/log/vmware/applmgmt/update_microservice.log. 

YYYY-MM-DD 16:13:18,362 - 52247 -           update_b2b::          verifyDownloadedRpms: 212 -    DEBUG - Staging error. Discrepancies exists between downloaded rpms and available updates
YYYY-MM-DD 16:13:18,362 - 52247 -         task_manager::                        update:  80 -    DEBUG - UpdateTask: status=FAILED, progress=0, message={'id': 'com.vmware.appliance.incomplete_staging', 'default_message': 'Incomplete staging. Discrepancies exists between downloaded and available updates', 'args': []}
YYYY-MM-DD 16:13:18,365 - 52247 -         task_manager::                        update:  80 -    DEBUG - UpdateTask: status=RESUMABLE, progress=0, message={'id': 'com.vmware.appliance.not_enough_disk_space', 'default_message': 'There is not enough space on the disk(s).  Increase disk space and try again.', 'args': []}
YYYY-MM-DD 16:13:18,367 - 52247 -          dbfunctions::                    executeDML:  54 -    DEBUG - Executing Query {INSERT INTO progress VALUES(NULL, ?,         DATETIME('now'), ?, ?, ?)} with parameters ('pre-check', 'No disk space available', 100, 95)
YYYY-MM-DD 16:13:18,377 - 52247 -           update_b2b::              installPrechecks:2248 -    DEBUG - Returning, no disk space available
YYYY-MM-DD 16:13:18,377 - 52247 -           update_b2b::                       install:2659 -    ERROR - Install prechecks phase failed.

Resolution

Try to unstage the staged patches.

  1. Log in to vCenter Server via SSH as the root user. When you log in to the appliance shell, the following prompt appears. If it does not appear, refer to KB: Toggling the vCenter Server Appliance default shell to switch to the appliance shell.

Connected to service

    * List APIs: "help api list"
    * List Plugins: "help pi list"
    * Launch BASH: "shell"

Command> 

  1. To unstage the patches, run this command.

Command> software-packages unstage

  1. Retry the patching process.

Additional Information

Toggling the vCenter Server Appliance default shell

Patching and Updating vCenter Server8.0 Deployments