Incident deletion job is failing on 25.1
search cancel

Incident deletion job is failing on 25.1

book

Article ID: 422602

calendar_today

Updated On:

Products

Data Loss Prevention Enterprise Suite

Issue/Introduction

Scheduled incident deletion job is failing after upgrading to DLP 25.1.

Localhost log shows:

SEVERE [com.symantec.dlp.incidentdomainservices.deletion.IncidentFlagDeletionSchedulerService] Failed to mark incidents for deletion while executing the flag incidents for deletion job for report: <Report Name>
Cause:
org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: com.vontu.enforceentities.users.Role.permissions, could not initialize proxy - no Sessionorg.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: com.vontu.enforceentities.users.Role.permissions, could not initialize proxy - no Session

Environment

Symantec Data Loss Prevention 25.1

Resolution

Solution is scheduled to be included in DLP 25.1 MP1 (tentative) and DLP 26.1 (tentative).

Workaround:

  1. Log into the DLP 25.1 Enforce Console as the default built-in Administrator
  2. Re-create the needed incident report.
  3. Then create a new deletion job pointing to the new report
    1. Enforce Console > System > Incident Deleter > Flag Incidents for Deletion
    2. Remember to remove the old deletion schedule pointing to the original report