Can't add a vCenter 8.x Workload domain as a Cloud Account In vCF Automation 9 with "Use cloud foundation managed service credentials" selected
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Can't add a vCenter 8.x Workload domain as a Cloud Account In vCF Automation 9 with "Use cloud foundation managed service credentials" selected

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Article ID: 422592

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Updated On:

Products

VCF Automation

Issue/Introduction

  • In VCF Automation 9, attempting to add a workload domain as a cloud account with the "Use cloud foundation managed service credentials" check box selected, you get the below error after clicking the button to create the service accounts:
    "Server <your-sddc-server.example.com> is down or not reachable, please check hostname or running environment"
  • The SDDC manager is not down, and is reachable on the network via ping and curl.
  • Rebooting SDDC manager and/or VCF Automation node makes no difference.

Environment

VCF Automation 9.0.x
vCenter 8.x

Cause

  1. The API Operations used by VCF 9.0.x to create the service accounts in vCenter do not exist in vCenter 8.x.
  2. Since the operations does not exist, the API returns a message that the server is unreachable.

Resolution

To work aroud the issue, do not Use Cloud Foundation Managed Service Accounts for vCenter 8.x Cloud account creation. 

  1. Generate the Service Accounts in vCenter Manually
  2. Create the Cloud Account in VCF Automation and provide the account details ensuring that the "Use cloud foundation managed service credentials" check box is not selected.