Fleet Manager binary download Stuck in IN_PROGRESS State from VCF Operations
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Fleet Manager binary download Stuck in IN_PROGRESS State from VCF Operations

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Article ID: 422501

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Updated On:

Products

VCF Operations

Issue/Introduction

The Fleet Manager binary download for a product component remains stuck in the IN_PROGRESS state even though the download has effectively completed. This prevents further operations that depend on the binary status. 

Environment

VCF Operations 9.0.1

Cause

The download status for one of the product components is not updated correctly in Fleet Manager. As a result, the component continues to show IN_PROGRESS in the product binary settings, even when the binary is already available.

This issue is caused by a rare race condition in which the request does not effectively update the status under database. As a result, the record remains in an in-progress state within the database.
Standard deletion or cancellation requests do not clear this condition, as they do not update or remove the affected database entry

Resolution

To work around this issue, use the Fleet Manager APIs to manually update the product binary download status from IN_PROGRESS to DOWNLOADED.

Refer to "How to Authorize VCF Operations Fleet Management API" before proceed with the below APIs

  1. Retrieve the current status of product binaries using the following API:
    curl -X GET "https://<Fleet_Manager_IP>/lcm/lcops/api/settings/productbinarysettings" -H "accept: application/json"

     
  2. Identify the component that is stuck in the IN_PROGRESS state.
     
    The sample response in your case will be:
     
    [
      {
    "productId": "vrni",
    "productVersion": "9.0.2.0",
    "productBinaryType": "install",
    "productBinaryPath": "VMware-Cloud-Foundation-Operations-for-Networks-9.0.1.0.25061250-platform.ova",
    "componentName": "platform",
    "mappingType": "Broadcom Depot",
    "productName": "VCF Operations for Networks",
    "requestId": null,
    "removeBinary": null,
    "depotType": null,
    "downloadStatus": "DOWNLOADED",
    "patchId": null,
    "size": null,
    "releaseDate": null
      },
      {
    "productId": "vrni",
    "productVersion": "9.0.2.0",
    "productBinaryType": "install",
    "productBinaryPath": "VMware-Cloud-Foundation-Operations-for-Networks-9.0.1.0.25061250-collector.ova",
    "componentName": "proxy",
    "mappingType": "Broadcom Depot",
    "productName": "VCF Operations for Networks",
    "requestId": null,
    "removeBinary": null,
    "depotType": null,
    "downloadStatus": "IN_PROGRESS",
    "patchId": null,
    "size": null,
    "releaseDate": null
      }
    ]
     
     
  3. Update the download status of the affected component to DOWNLOADED using the POST API call with the appropriate payload:

    Below is an example for 'VCF Operations for Networks'. Likewise, update the downloadStatus for all the ProductName reporting "IN_PROGRESS"

    curl -X POST "https://<Fleet_Manager_IP>/lcm/lcops/api/settings/productbinarysettings" \
         -H "accept: application/json" \
         -H "Content-Type: application/json" \
         -d '[ { 
               "productId": "vrni",
               "productVersion": "9.0.2.0",
               "productBinaryType": "install",
               "productBinaryPath": "VMware-Cloud-Foundation-Operations-for-Networks-9.0.2.0.25061250-collector.ova",
               "componentName": "proxy",
               "mappingType": "Broadcom Depot",
               "productName": "VCF Operations for Networks",
               "requestId": null,
               "removeBinary": null,
               "depotType": null,
               "downloadStatus": "DOWNLOADED",
               "patchId": null,
               "size": null,
               "releaseDate": null
             } ]'

     
     
  4. Verify that the component status is now updated to DOWNLOADED.