ConnectALL did not sync back the Change Number to Jira when Change is created in ServiceNow with error 'Rate Limiting Exception in getting the user timezone'
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ConnectALL did not sync back the Change Number to Jira when Change is created in ServiceNow with error 'Rate Limiting Exception in getting the user timezone'

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Article ID: 422484

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Updated On:

Products

ConnectAll SaaS ConnectAll On-Prem ConnectALL

Issue/Introduction

A CR was created in Service Now, but the CR # didn't go back to Jira. 

Environment

3.9

Cause

Logs shows error below for said transaction. It appears that Jira rate limit caused the sync of CR# failed to Jira.

.connectall.adapter.model.exception.ConnectAllRateLimitExceededException: Rate Limiting Exception in getting the user timezone : {"errorMessages":["The request has been rate-limited. Please try again later."],"errors":{},"status":429}

Resolution

ConnectALL adds such records in retry_queue if failed due to Rate Limit and those will be processed in next run after cool off period is over.