mon_config_service probe logsize grown to unmanageable size
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mon_config_service probe logsize grown to unmanageable size

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Article ID: 422446

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Get a blank page when viewing the mon_config_probe logs in IM and when checking the mon_config_service probe folder see the logs are not rotating and the probe log size is 24GB 

Also trying to deactivate the probe in IM which shows no port/pid still cannot delete the logfile as says the file is still locked by java process 

Environment

UIM 23.4.5

probe :mon_config_service 

Cause

A Java process that failed to terminate and is still holding an open file handle

Resolution

Using windows resource monitor we could see two java processes with different pids having associated handles on the mon_config_service folder on the Primary hub 

When the mon_config _probe was deactivated in IM still we can see one java process running in the background for the mon_config_service folder / files 

  • Press Win + R, type resmon, and press Enter. This will open Resource Monitor.
  • Go to the CPU tab.
  • In the Associated Handles section, use the search box to enter part of the file or folder name. In this case "mon_config_service"
  • The results will show which processes are using the file. Check the Image and PID columns to identify the process.
  • Right-click the process and select End Process (be cautious when ending processes).

The large 24GB log file could now be deleted 

After this was done and mon_config_service probe activated only one java process/pid is see handling the probe as expected