After removing stale host records from the NSX inventory, references to these hosts remain in the vrNI-Node_Group_Profile_* groups created by VCF Operations for Networks
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After removing stale host records from the NSX inventory, references to these hosts remain in the vrNI-Node_Group_Profile_* groups created by VCF Operations for Networks

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Article ID: 422392

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Updated On:

Products

VCF Operations for Networks VMware NSX

Issue/Introduction

  • Stale host transport node references were recently removed from the NSX inventory via editing the Corfu database.
  • The vrNI-Node_Group_Profile_* groups created by VCF Operations for Networks retain references to these hosts. 
    • These references are via API path, not hostname, for example:

      /infra/sites/default/enforcement-points/default/host-transport-nodes/######

  • These groups cannot be edited to remove the stale host references.
  • The NSX data source in VCF Operations for Networks has a message stating, "Data collection failed due to an error."

Environment

  • VCF Operations for Networks
  • VMware NSX

Cause

Removing host transport nodes from the NSX inventory via editing the Corfu database can leave references to these hosts behind. The groups will need to be deleted and recreated for the stale host references to be removed.

Resolution

If the environment is VCF 9.x and the NSX data source was created via an integration in VCF Operations:

  1. In the VCF Operations UI, navigate to Administration > Integrations > VMware Cloud Foundation > <workload domain> > <NSX instance>.
  2. Click the three vertical dots next to the NSX instance and select Edit.
  3. Disable latency metric collection and click the Save button.
    Note: If the NSX manager is used in multiple workload domains, it will only need to be edited once.
  4. Repeat Steps 1 - 3 but enable latency metric collection at Step 3.

If the environment is not VCF 9.x or the NSX data source was configured directly in VCF Operations for Networks:

  1. In the VCF Operations for Networks UI, navigate to Settings > Accounts and Data Sources.
  2. Click the three vertical dots next to the NSX data source and select Edit.
  3. Expand the Additional Information section and disable latency metric collection. Click the Submit button.
  4. Repeat Steps 1 - 3 but enable latency metric collection at Step 3.