ArgoCD CLI Login Fails with I/O Timeout
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ArgoCD CLI Login Fails with I/O Timeout

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Article ID: 422389

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

  • Post-deployment of ArgoCD as a Supervisor Service, the argocd login command fails with the following error.

argocd login #.#.#.# --insecure

FATA[0191] Failed to establish connection to #.#.#.#:443: dial tcp #.#.#.#:443: i/o timeout

  • Successfully logged into the ArgoCD Web UI; the issue is isolated to the CLI.
  • All ArgoCD pods are running and healthy.
  • Validate the ArgoCD config map configuration (server.insecure

    kubectl get cm argocd-cmd-params-cm -o yaml

    apiVersion: v1

    data:

       ...
       server.insecure: "true"
       ...
    kind: ConfigMap

     

Environment

vSphere 9.x

Cause

The ArgoCD server is configured in the ConfigMap with server.insecure: "true", meaning it expects unencrypted HTTP (plaintext) traffic.
The default CLI login command attempts to establish a secure HTTPS (TLS) connection, since the server is not listening for TLS, it resets the connection during the handshake.

Resolution

To successfully login to ArgoCD when the server is set to accept only http traffic, Execute the login command using the --plaintext flag to match the server's configuration:

argocd login #.#.#.# --skip-test-tls --plaintext

Additional Information

vSphere Supervisor Services and Standalone Components