DevTest doesn't start and log file is also not created
search cancel

DevTest doesn't start and log file is also not created

book

Article ID: 422336

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

When trying to start the Registry service, it stops immediately.

Log file also not generated to check any possible issue.

Environment

DevTest 10.x

Cause

To understand the issue launch the Registry service command in DEBUG mode. Below is the command.

./RegistryService start-launchd

It gave below error:

<DevTest_Home>/bin> ./RegistryService start-launchd
Starting RegistryService
Could not create id file /tmp/i4jdaemon__xxx_xxx_xxx__bin_RegistryService. Aborting.

The /tmp folder is a temporary landing place for files on LINUX.  When DevTest starts a service it will create a file which holds a process ID in the operating system /tmp directory. 

Resolution

The identify error means that RegistryService is unable to create a process and related file in the /tmp location.

Check with the Linux admin team to understand why DevTest component is not able to create the file. 

Possible causes could be less permissions, /tmp space is out of space, etc.