Spectrum-LDAP integration not working when a Landscape is down with error: "SecuritySP -could not perform LDAP user search"
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Spectrum-LDAP integration not working when a Landscape is down with error: "SecuritySP -could not perform LDAP user search"

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Article ID: 422282

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

LDAP integration is enabled and users access Spectrum with LDAP credentials. This setup is working fine when all the landscape are up and running in the Spectrum environment. Once one of the landscape shuts down, none of the users can login via ldap credentials.

With SSORB Security SP debug enabled under:

OneClick WEB GUI -> Administration -> debugging -> Web Server Debug Page (Runtime)

The following exceptions are repeatedly seen in the OneClick server log:

2025-08-26 16:00:48,415 [https-comp-me-8443-exec-23] INFO  com.aprisma.debuglog -  (SecuritySP) - could not perform LDAP user search or get the search results

2025-08-26 16:00:48,415 [https-comp-me-8443-exec-23] WARN  System.err - javax.naming.CommunicationException: Request: 11062 cancelled; remaining name 'OU=NMS,DC=company,DC=com,DC=au’

 

The following attempted resolutions do not work:

  1. Syncing users across all landscapes as per the following, doesn't make any difference, problem remains:

    KB : Error: “The Landscape is Not Available” generated when using Spectrum Service Editor


  2. Using workaround which is to disable LDAP Group Authentication by editing the file:

    $SPECROOT/custom/ldap/config/ldap-grps-mappings-config.xml

    Then in that file,  disable it by setting the following to false:

    <LDAPGroups authEnabled="false">

    But users can’t access OneClick since they don’t have any password set locally for any users, so above work-around doesn't work.

 

Environment

DX NetOps Spectrum 24.3.x

Cause

Issue when handling LDAP Group authentication

Resolution

The fix for this issue is included in the 25.4.2 release of Spectrum as detailed:

TechDocs : DX NetOps Spectrum 25.4 : Resolved Issues in 25.4.2

  • Symptom: LDAP integration does not work when one of the landscapes, which is part of the Spectrum DSS environment, is down.

  • Solution: With this fix, Spectrum updates the code to ensure that the LDAP Integration now works successfully when one of the landscapes, which is part of the Spectrum DSS environment, is down.
     
    (DE176296, 36567402, 25.4.2)