Brightmail Engine stops unexpectedly and is not restarted
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Brightmail Engine stops unexpectedly and is not restarted

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Article ID: 422252

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Updated On:

Products

Messaging Gateway

Issue/Introduction

During normal operation of the Messaging Gateway, the Brightmail Engine process stops and is not automatically restarted as expected.

messages log
2025 Dec  3 18:41:04 (err) kernel: [-] Out of memory: Killed process 2603 (bmserver) total-vm:19947432kB, anon-rss:12150852kB, file-rss:8400kB, shmem-rss:1152kB, UID:1000 pgtables:34576kB oom_score_adj:0

Cause

Low system memory causes the operating system kernel to kill processes using a large amount of memory. This issue appears to only occur in virtual infrastructure where the configured RAM is less than the recommended memory for the Messaging Gateway release, or that some limits, like maximum message size, have been significantly increased from their default values.

Resolution

This issue is under investigation for final determinations.

A current workaround is to add additional RAM to the virtual machine appears to resolve the issue.