processes probe stopped collecting metrics
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processes probe stopped collecting metrics

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Article ID: 422194

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

The processes probe stopped collecting metrics for all machines in one domain/environment, and we have not received any data for the last 16 hours.

Environment

  • DX UIM 23.4 CU4
  • processes probe version 4.85-T1

Cause

  • Somehow a downgrade of the template seemed to be automatically processed
  • unknown root cause
  • Using probe callbacks to downgrade processes probe template to an older version could not reproduce the issue

Resolution

Repaired some group level process profiles using the following queries. Below are the sample queries we performed for groups.

--To list all group ids that have corrupted template id
select distinct group_id from SSRV2Profile where template=1915 and group_id is not null;

--To take a bunch of groups from list produced by the statement above
select * from ssrv2profile where template=1915 and group_id in (1216,1234,1236,2794,2795);

select * from ssrv2profile where template=1915 and ancestorprofile in (select profileId from SSRV2Profile where template=1915 and group_id in (1212,1213, 1214, 1215));

update SSRV2Profile set template=2532 where template=1915 and group_id in (1212, 1213, 1214, 1215);

update SSRV2Profile set template=2532 where template=1915 and ancestorprofile in (select profileId from SSRV2Profile where template=2532 and group_id in (1212, 1213, 1214, 1215));

update ssrv2profile set status= 'modified' where template=2532 and group_id in (1212, 1213, 1214, 1215);
select * from ssrv2profile where template=2532 and ancestorprofile in (select profileId from SSRV2Profile where template=2532 and group_id in (1212,1213, 1214, 1215))