API-1019 on MUX timesheet when editing time entries
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API-1019 on MUX timesheet when editing time entries

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Article ID: 422152

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A couple of users are getting an API-1019 error on MUX timesheets when editing time entries, however they can update the same timesheets through the Classic UI interface.

The app-ca.log file shows the following error:

ERROR 2025-11-28 16:03:41,781 [http-nio-80-exec-27] ppm.rest (clarity:myuser:mysession:PPM_REST_API)
com.ca.ppm.rest.exception.APISystemException: java.lang.NullPointerException: Cannot invoke "com.niku.union.odf.ObjectInstance.getData()" because "parentInst" is null
    at com.ca.platform.osf.object.rest.provider.ODFResourceProvider.updateEntity(ODFResourceProvider.java:1500)

Developer tools throws a 500 error response on the following PUT:
 
http://myClarityserver/ppm/rest/v1/timesheets/5368897/timeEntries/6306787
 

 

Environment

Clarity 16.3.3

Cause

This is caused by duplicated entries of the affected resource on the prcalendar table.

Resolution

If the following query returns any data please open a support ticket to work on a resolution:

SELECT prresourceid, count(*)
FROM prcalendar
WHERE prresourceid IS NOT NULL
GROUP BY prresourceid
HAVING count(*) > 1