High latency observed when transmitting the TCP segment.
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High latency observed when transmitting the TCP segment.

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Article ID: 422130

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • High Latency was observed when sending a TCP segment
  • The hashed uplink associated with the application VM is showing “Total Received Errors” and “Receive Length Errors” within the vmnic counters.

    [root@esx-01:~] esxcli network nic stats get -n vmnic1
    NIC statistics for vmnic1
       Packets received: 80950091667
       Packets sent: 92725897160
       Bytes received: 63939019413776
       Bytes sent: 82980949480274
       Receive packets dropped: 0
       Transmit packets dropped: 0
       Multicast packets received: 3533425885
       Broadcast packets received: 3846884099
       Multicast packets sent: 24248039
       Broadcast packets sent: 6124237
       Total receive errors: 8395
       Receive length errors: 6584

Environment

VMware ESXi 8.x

Cause

The data reflected by these counters represents issues external to the ESXi kernel and only includes what is reported to the ESXi host by the NIC driver.

When these counters show elevated values, monitoring the rate at which they increase can provide valuable insight. To observe these counters in real time and determine whether the values are incrementing, please use the following command:

$ watch esxcli network nic stats get -n vmnic#

It is important to note that, in some cases, the counter values may appear significantly high, and it may not be clear whether these increments are recent or related to a previous issue. In such situations, it can be beneficial to clear the counters before continuing the investigation. To reset the values, the ESXi host must be rebooted:

  • Record the current values of the counters.
  • Place the ESXi host into Maintenance Mode.
  • Reboot the ESXi host.
  • After the host comes back online, the counter values will be reset to zero.

In a healthy environment, the number of reported “errors” should either be zero or very minimal relative to the overall traffic.

Resolution

If any NICs are reporting errors, please engage your hardware vendor for further analysis, as these physical NIC issues are detected and reported directly to the ESXi host.

Additional Information

Related articles.

Troubleshooting NIC errors and other network traffic faults in ESXi