応答の無い状態のホストへの SSH 接続が失敗し、DCUI へのログインでは次のエラーが表示される : "/bin/dcuiweasel: line #: can't fork: File too large"
search cancel

応答の無い状態のホストへの SSH 接続が失敗し、DCUI へのログインでは次のエラーが表示される : "/bin/dcuiweasel: line #: can't fork: File too large"

book

Article ID: 422093

calendar_today

Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

免責事項:これは英文の記事「SSH attempt to unresponsive ESXi 8.0u3 host fails and DCUI errors out with "/bin/dcuiweasel: line #: can't fork: File too large"」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • 対象 ESXi ホストの SSH を有効にできない
  • 対象 ESXi ホストの SSH が有効となっている場合でも、SSH 接続が失敗する
  • 対象ホストへの vMotion、または、対象ホストからのvMotionが失敗する
  • DCUI(Direct Console User Interface)へのログインが次のエラーでスタックする

    /bin/dcuiweasel: line #: can't fork: File too large

  • コマンドの起動が失敗し、/var/log/vmkernel.log に下記のエラーが記録される

    YYYY-MM-DDThh:mm:ss.397Z In(18#) vmkernel: cpu##:95538## opID=c1aae###)World: ##: VC opID m1hkp###-21###-auto-gag-h5:70002###-2#-60-#### maps to vmkernel opID c1aae###
    YYYY-MM-DDThh:mm:ss.397Z Wa(18#) vmkwarning: cpu##:95538## opID=c1aae###)WARNING: Sched: vm 160089##: 63##: could not create container group, status: Limit exceeded
    YYYY-MM-DDThh:mm:ss.397Z Wa(18#) vmkwarning: cpu##:95538## opID=c1aae###)WARNING: Sched: vm 160089##: 63##: could not create container group, status: Limit exceeded

  • /var/run/log/hostd.log に下記と類似のエラーが記録される

    YYYY-MM-DDThh:mm:ss.208Z Er(163) Hostd[20996##]: [Originator@6876 sub=SysCommandPosix opID=CSMM-domain-c370915-39762-d### sid=52738### user=vpxuser] Failed to ForkExec /usr/lib/vmware/clusterAgent/bin/clusterAdmin: File too large
    YYYY-MM-DDThh:mm:ss.443Z Er(163) Hostd[20996##]: [Originator@6876 sub=SysCommandPosix opID=CSMM-domain-c370915-39763-d### sid=52738### user=vpxuser] Failed to ForkExec /usr/lib/vmware/clusterAgent/bin/clusterAdmin: File too large

Environment

vSphere ESXi 8.0 Update 3

Cause

システムで許可されているプロセス数を超える非常に多数のプロセスが何度も起動された場合、またはメモリリソースの不足によりプロセスの起動が何度も失敗した場合に新しいプロセスを起動できなくなる可能性があります。

この問題により、ESXiホストが応答しなくなる可能性があります。

Resolution

この問題は ESXi 8.0u3e で修正されています。こちらのリンクからダウンロードが可能です。

 Broadcom Support Portal

 

対処:
ESXi ホストを再起動し、ホストの応答性と SSH 接続を復旧します。