VMware Kubernetes サービスでコンテンツ ライブラリを変更した後、TKR バージョンの取得が「リソースが見つかりません」というエラーで失敗する
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VMware Kubernetes サービスでコンテンツ ライブラリを変更した後、TKR バージョンの取得が「リソースが見つかりません」というエラーで失敗する

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Article ID: 422053

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VMware vSphere Kubernetes Service

Issue/Introduction

免責事項:これは英文の記事「TKR Version Retrieval Fails with the error: “No resources found” After Content Library Change in VMware Kubernetes Service」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


vSphere スーパーバイザー クラスタで新しく作成されたコンテンツ ライブラリに切り替えた後、Tanzu Kubernetes リリース (TKR) のバージョンを取得しようとすると、次のエラーが発生する場合があります。

警告: run.tanzu.vmware.com/tanzukubernetesrelease は非推奨です。kubernetes.vmware.com/kubernetesrelease が後継です。ドキュメントを参照してください。リソースが見つかりません。

この問題により、スーパーバイザー クラスタは利用可能な TKR バージョンを検出できず、クラスタのプロビジョニングとライフサイクル操作に影響を及ぼします。

Environment

VMware vSphere Kubernetes Service

Cause

この問題は、既存のライブラリからアイテムを複製して新しいコンテンツライブラリにアイテムを追加した場合に発生します。コンテンツライブラリのアイテムは、元のソースにリンクするメタデータを保持しています。このメタデータの不一致により、TKRバージョンのリソース検出プロセスが中断されます。

エアギャップ環境では、コンテンツライブラリのアイテムの不適切な複製によって関連付けが失われ、TKRメタデータの取得に失敗する可能性があります。

Resolution

問題を解決するには、以下の手順を実行してください。

1. 元のコンテンツライブラリへのロールバック:スーパーバイザークラスタを、以前TKRバージョンにアクセスできた元のコンテンツライブラリを使用するように戻します。これにより、正しいメタデータの関連付けが復元され、リソース検出の失敗が解決されます。

2. コンテンツライブラリ管理の公式手順に従う:コンテンツライブラリを作成または更新する際(特にエアギャップ環境の場合)、プロセスがBroadcomの文書化されたベストプラクティスに準拠していることを確認してください。

🔗 https://techdocs.broadcom.com/us/en/vmware-cis/vcf/vsphere-supervisor-services-and-standalone-components/latest/managing-vsphere-kubernetes-service/administering-kubernetes-releases-for-tkg-service-clusters/edit-an-existing-content-library.html


🔗 https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere-supervisor/8-0/using-tkg-service-with-vsphere-supervisor/administering-kubernetes-releases-for-tkg-service-clusters/create-a-local-content-library-for-air-gapped-cluster-provisioning.html

 

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