Status is "Disconnected" in VCF Operations Fleet Management after manual password update
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Status is "Disconnected" in VCF Operations Fleet Management after manual password update

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Article ID: 422045

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Updated On:

Products

VCF Operations

Issue/Introduction

After manually updating the vmware-system-user password (out-of-band) on virtual machines (for example, via single user mode or at the OS level), VCF Operations Fleet Management displays the password status as "Disconnected".

You can successfully log in to the VM via SSH using the new password, but the Fleet Management UI does not reflect the change. Attempting to use the standard "Update" function in Fleet Management fails with error: LCMVMSP10019.

Environment

  • VCF Operations

Cause

This issue occurs because the password was changed directly (out-of-band) on the Operating System, causing passwords to go out of sync between what was previously stored in the VCF Operations environment and the actual credentials on the component VM(s).

VCF Operations does not poll for password changes in real-time. Additionally, the standard "Update" workflow in Fleet Management fails in this scenario because it attempts to authenticate using the old (stored) password to set a new password. Since the old password is no longer valid on the OS, the handshake fails.

Resolution

To resolve the "Disconnected" status, use the Remediate function to update the stored credential without initiating a password change command on the appliance.

  1. In VCF Operations, navigate to Fleet Management > Passwords > VCF Management
  2. Select the VCF Component for the User Name that needs password remediation
  3. Select the Remediate Password button (do not select "Update Password").
  4. Input the new password that was already set (out-of-band) on the VM
  5. Click the Remediate Password button
  6. If the status does not update immediately, trigger a manual Inventory Sync from Fleet Management > Lifecycle > VCF Management > Components (click the Component link and then click 'Trigger Inventory Sync')

    Note: Since the password check occurs periodically, it may take anywhere from 1 to 24 hours for the password to show as green and 'Active'

 

Additional Information

Remediate Passwords for VCF Components

To view current system passwords, utilize the Fleet Management API. For more information, see KB 412001.