After changing vCenter IP address, lookupsvc fails to start.
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After changing vCenter IP address, lookupsvc fails to start.

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Article ID: 422020

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

After changing the IP address for vCenter Server the lookupsvc fails to start, preventing other critical services from starting like STS.

After rebooting or manually starting services they appear like the below screenshot:

service-control --status --all

 

When checking the vmafdd.log we see messages like the below screenshot:

This shows that the vmafd service is still trying to connect to the old IP address.

 

Environment

vCenter 8.0u3

Cause

No cause has been confirmed for this but it is suspected that the vCenter may have had it's FQDN set as it's IP address at some point or other DNS issues.

Resolution

To resolve this issue, use the below command to set the "DC Name" parameter to the vCenter Server's FQDN to clear any mix ups with it using the old IP address.

 

/opt/likewise/bin/lwregshell set_value '[HKEY_THIS_MACHINE\Services\vmafd\Parameters]' DCName <VC_FQDN>

 

Note: be sure to replace <VC_FQDN> with the vCenter Server's FQDN.