HCX : Service Mesh Deletion Fails with "Interconnect Service Workflow InterconnectRemoveAppliance failed"
search cancel

HCX : Service Mesh Deletion Fails with "Interconnect Service Workflow InterconnectRemoveAppliance failed"

book

Article ID: 421949

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Unable to delete HCX Service Mesh as it fails with the error below.

Interconnect Service Workflow InterconnectRemoveAppliance failed. Error: Unknown
or
Error: JSONObject["vcenterinstanceld"] not found.

  • Force Delete option on the Service Mesh also fails.
  • Login to the HCX manager as user admin and check for the error message below in the log file /common/logs/admin/app.log

[InterconnectService_SvcThread-20, IX:######-####-####-#######, J:#######, , TxId: ######-####-####-#######] ERROR c.v.v.h.s.i.InterconnectRemoveApplianceJob- The configuration for this VCenter UUID : ######-####-####-#######, URL:null in Appliance Config is incomplete, please check credentials and validity of vc certificate

Environment

VMware HCX

Cause

  • The vCenter credentials or certificates were changed and not updated with the HCX manager.
  • Service Mesh Deletion fails if the vCenter is out-of-sync with the HCX which impacts the authentication and connectivity between the HCX Manager and the registered vCenter Server.
  • The HCX deletion workflow requires successful connectivity with the registered vCenter.

Resolution

  • Re-establish the vCenter connectivity with the HCX manager

Verify HCX Connectivity

    • Log in as an admin user to the HCX Appliance Management UI <https://hcx-manager-ip-or-fqdn:9443>

    • Navigate to the Dashboard and ensure that the status for vCenter is displaying as Green.

Re-register vCenter with HCX Manager

    • If vCenter status is red/yellow, please re-register the vCenter within the HCX Manager settings via <https://hcx-manager-ip-or-fqdn:9443> and click on the Configuration tab --> vCenter --> Edit

    • Provide the corresponding vCenter credentials.
    • After re-registration, reboot the HCX Manager to apply the configuration changes.

  • Try deleting the Service Mesh

 

Additional Information

Refer to the KB Uninstall a deployment from Connector & Cloud to know about the end-to-end workflow to remove HCX services on-premises and cloud.