Unable to import VCF Operations for logs in VCF Operations fleet manager
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Unable to import VCF Operations for logs in VCF Operations fleet manager

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Article ID: 421941

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Updated On:

Products

VCF Operations

Issue/Introduction

  • When attempting to import a previously deployed VCF Operations-Logs appliance from a management vCenter into VCF Operations, the import process fails. Although the appliance user interface (UI) is accessible and functional, the import returns the following error: Failed to save details. Please try again.
  • The fleet manager logs at /var/log/vrlcm/vmware_vrlcm.log show the following error: ERROR vrlcm[1361] [pool-3-thread-5] [c.v.v.l.u.RetryUtil] – Attempt 5 failed: com.vmware.vrealize.lcm.common.exception.userinput.vrli.VrliRestHostNameInvalidException com.vmware.vrealize.lcm.common.exception.userinput.vrli.VrliRestHostNameInvalidException: null

Environment

VCF Operations for logs 9.x

VCF Operations 9.x

Cause

The VCF Operations for logs appliance was deployed using a short hostname instead of a full Fully Qualified Domain Name (FQDN). Fleet Manager attempts to communicate using this short name, but it cannot be resolved.

Resolution

To resolve this issue, you must update the hostname to a full FQDN using one of the two methods below:

Method 1: vCenter UI

  1. Log in to the vCenter UI.
  2. Select the VCF operations for logs VM.
  3. Navigate to Configure > vApp Options.
  4. Update the hostname to the full FQDN.

Method 2: Command Line (SSH)

  1. SSH into the operations-logs VM.
  2. Update the hostname using the hostname command:
    hostname <full_FQDN>

Final Step

After updating the hostname, retry the import:

    1. Navigate to VCF Operations > Fleet management.
    2. Go to Lifecycle > Tasks.
    3. Retry the failed import task.