Unable to import operations-logs in VCF Operations fleet manager.
search cancel

Unable to import operations-logs in VCF Operations fleet manager.

book

Article ID: 421941

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When attempting to import a previously deployed VCF Operations-Logs appliance from a management vCenter into VCF Operations, the import fails. Although the appliance's user interface (UI) is accessible and functional, the import process returns the following error:
    Failed to save details. Please try again.

     

  • In the fleet manager logs at /var/log/vrlcm/vmware_vrlcm.log  we see error:
    ERROR vrlcm[1361] [pool-3-thread-5] [c.v.v.l.u.RetryUtil] – Attempt 5 failed: com.vmware.vrealize.lcm.common.exception.userinput.vrli.VrliRestHostNameInvalidException
    com.vmware.vrealize.lcm.common.exception.userinput.vrli.VrliRestHostNameInvalidException: null

Environment

VCF Operations for logs 9.x

VCF Operations 9.x

Cause

operations-logs appliance was deployed with short hostname instead full FQDN. Fleet management is trying to communicate to that short name but it cannot be resolved.

Resolution

  1. Update the hostname to full FQDN in vCenter UI by selecting the VM → Configure → vApp Options

    or

    SSH to the operations-logs VM and update the hostname with hostname command as follows:

    hostname <VCF-logs FQDN>

  2. Retry the import in VCF Operations → Fleet management → Lifecycle → Tasks page.