vSphere Client で Active Directory または外部 ID ソースユーザーのパスワードを変更できない
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vSphere Client で Active Directory または外部 ID ソースユーザーのパスワードを変更できない

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Article ID: 421903

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VMware vCenter Server

Issue/Introduction

免責事項: これは英文の記事「Cannot Change Password for Active Directory or External Identity Source Users in vSphere Client」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事を参照してください。

vSphere Client を使用してユーザーのパスワードを変更しようとすると、操作が失敗し、エラーが表示されます。

具体的には、パスワード変更を試みた方法に応じて、以下のいずれかのエラーメッセージが表示されます。

  1. ユーザー自身が自分のパスワードを変更しようとした場合:
    ドメインユーザーとしてログインし、ユーザーメニューから「パスワードの変更」を選択した後、以下のエラーが表示されます。

    「指定された名前のシステム ドメインのユーザーが存在しないか、入力されたパスワードが正しくありません」

  2. 管理者が他のユーザーのパスワードを変更しようとした場合:
    SSO 管理者(例: [email protected])としてログインし、[管理] > [Single Sign-On] > [ユーザーとグループ] に移動し、対象ユーザーを編集(パスワードの変更)しようとすると、以下のエラーが表示されます。

    「指定された名前のプリンシパルが存在しません 」

Environment

VMware vCenter Server

Cause

この問題は、対象のユーザーアカウントが、vCenter Single Sign-On (SSO) のローカルドメイン(例: vsphere.local)ではなく、外部 ID ソース(Active Directory や OpenLDAP など)に属しているために発生します。

Resolution

この動作は仕様です。

vSphere Client は、vCenter Single Sign-On のローカルドメインに存在するユーザーのパスワードを管理するためにのみ設計されています。外部ディレクトリサービスに属するユーザーのパスワードを変更する機能は持っていません。

外部ドメイン(例: Active Directory)に属するユーザーのパスワードを変更するには、vSphere Client を使用しないでください。

代わりに、外部ディレクトリサービス(例: Active Directory の場合は ユーザーとコンピューター、またはオペレーティングシステムのパスワード変更ユーティリティなど)によって提供されるネイティブのパスワード管理方法を使用してください。