CLRT-77615 Upgrade to 14.2 can fail with errors referencing java.lang.NullPointerException on JDBCSecurePasswordTask.getConnection() call
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CLRT-77615 Upgrade to 14.2 can fail with errors referencing java.lang.NullPointerException on JDBCSecurePasswordTask.getConnection() call

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Article ID: 42187

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Problem:

 

Upgrading to 14.2 can fail and need redoing if prior to the upgrade the properties.xml contains an <encryption> element with no useSystemKey="true|false" attribute value present.
 
The file would include the following output example when this problem occurs:
 
4/25/15 2:08 AM (admin) java.lang.NullPointerException
4/25/15 2:08 AM (admin) at com.niku.tools.taskdefs.JDBCSecurePasswordTask.getConnection(JDBCSecurePasswordTask.java:44)
4/25/15 2:08 AM (admin) at com.niku.tools.taskdefs.SQLTask.execute(SQLTask.java:540)
4/25/15 2:08 AM (admin) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
4/25/15 2:08 AM (admin) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
4/25/15 2:08 AM (admin) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
 

Steps to Reproduce:

  1. Install Clarity and get it working with basic setup
  2. Go into the CSA and navigate to the properties > security tab
  3. Without changing anything, click on Save
  4. Check the properties.xml, the <encryption> element will have been created but no attribute for useSystemKey exists
  5. Upgrading at this point will cause the error

Expected Result:  Upgrade to complete without encountering this error

Actual Result: Upgrade will encounter this error in a few places (e.g. post-upgrade scripts) and fail with an incomplete upgrade

 

Environment:

Applies to all supported PAS environments for upgrades to CA PPM 14.2.  

Cause:

Caused by CLRT-77615

Resolution:

Resolved in CA PPM 14.3

Workaround:

  1. Go back to the CSA properties > security tab before upgrade
  2. Under the Encrypt Passwords section change the setting (e.g. from No Encryption to Using System Key)
  3. Click on Save
  4. Change the setting back again (e.g. from Using System Key to No Encryption)
  5. Click Save again.

Now the <encryption> element will exist and the useSystemKey attribute should exist too. Now the upgrade should proceed without error.

It is best to do this workaround proactively and avoid the need to rollback and redo the upgrade.

 

Additional Information:

Reference Release Notes and CA PPM Resolved Defects Index for CA PPM 14.3

Environment

Release: ESPCLA99000-14.2-Clarity-Extended Support Plus
Component: