ESXi SSH access is unavailable. Error: Unable to enable SSH; inetd not running
search cancel

ESXi SSH access is unavailable. Error: Unable to enable SSH; inetd not running

book

Article ID: 421851

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vSphere ESXi 8.0

Issue/Introduction

  • SSH enabled through DCUI (Direct Console User Interface)/Host Client.
  • SSH connection attempt results in: Network Error: Connection Refused message.
  • Restarting the SSH service still results in: Network error: Connection Refused, and connection fails.
  • Hostd.log
    The hostd.log shows the following sequence of events:
2025-12-09T09:05:41.033Z In(166) Hostd[2100103]: [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 61940 : SSH access has been enabled.
2025-12-09T09:05:41.093Z In(166) Hostd[2100079]: [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 61941 : Issue detected on ESXi_Host_FQDN in ha-datacenter: Unable to enable SSH; inetd not running

Environment

vSphere ESXi

Cause

 

  • inetd failed to restart after the busybox process terminated.

  • The inetd.conf file is located in /var/run and is not referenced when the inetd service is manually restarted.

 

Resolution

Restart inetd by explicitly referencing the /var/run/inetd.conf file.

Workaround :

  1. Verify SSH Status: Check that SSH is enabled in the DCUI - Troubleshooting Options.

  2. Access ESXi Shell: Connect to the ESXi Shell via the DCUI (Press Alt+F1).

  3. Execute Command: Run one of the following commands:

    # /usr/lib/vmware/busybox/bin/busybox inetd /var/run/inetd.conf
    

    OR

    # inetd /var/run/inetd.conf
    
  4. Check PID: Note the Process ID (PID) in /var/run/inetd.pid.

  5. Confirm Process: Check if the PID of the running busybox or inetd process matches the value noted in step 3.

    # ps | grep busybox
    

    OR

    # ps | grep inetd
    
  6. Test Connection: Attempt the SSH connection test.