CA Chorus Software Manager start fails with S0C4 after new maintenance was deployed
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CA Chorus Software Manager start fails with S0C4 after new maintenance was deployed

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Article ID: 42182

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Updated On:

Products

Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Symptoms:

After install of below mentioned maintenance to CA Chorus Software Manager and running MSMDEPLY, MSMTC start up fails with:

MSM0013I CA CSM STARTUP INITIATED                              

MSMMUF:DB00903I - OPENED, BASE -  4000                         

SECIN15I CA DSI Server r14.0 has terminated abnormally         

IEF450I MSMTC2 STEP1 - ABEND=S0C4 U0000 REASON=00000004 499    

        TIME=15.47.25                                          

MSM0009I CA CSM STARTUP COMPLETE

 

The MSMTC log shows this fatal error:

FATAL (localhost-startStop-1) 2016-05-02 15:47:25,590 (SystemManager.java:296): A fatal error has occurred while starting up SAF Manager

com.ca.mf20.zos.api.process.errors.UssProcessTerminatedError: MME0260S - Process 0x2000080 terminated by signal 0xB.

Attached Internal Log:

MME0260S - Process 0x2000080 terminated by signal 0xB.

 

Environment

CA CSM 5.1 with Build 126 (RO88559) or higher

CA CSM 6.0 with Build 131 (RO88533) or higher

CA CSM 6.1 with Build 78 (RO88731) or higher 

Cause

Neglected to execute Holdaction as outlined in the PTF

Resolution

  1. Locate dsi.conf file in .../msmruntime/dsi/ directory 
  2. Verify the value of "threads" is set to 32.         
  3.  Restart MSMTC 
In some cases it was also needed under /u/CA_CSM/CSM/msmruntime/apache-tomcat-7.0.42/webapps/  (or whatever the CSM Tomcat directory is pointing to)
to delete the MSM directory and be sure not to delete the MSM.war file then restart MSMTC.
During MSMTC start the MSM directory will be created again.