Secondary server upgrade failed with JDBC database connection error in install.log
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Secondary server upgrade failed with JDBC database connection error in install.log

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Article ID: 421762

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

We tried to upgrade the secondary server from 17.3 RU04 to 17.4 and the upgrade failed. %TEMP%\casm\install.log shows

2025/12/05 12.41.45.132 INFO  [AWT-EventQueue-0] [DatabasePersister] Unable to obtain Database Connection for user : mdbadmin May be a fresh installation.El número de puerto  no es válido.
(English translation: The port number is invalid)
2025/12/05 12.41.45.132 ERROR [AWT-EventQueue-0] [DatabasePersister] Connection to get JDBC database connection failed

Environment

Service Desk Manager Conventional Configuration secondary server 17.x

Cause

For secondary server upgrade, no need to enter database connection info.

Resolution

As the secondary server does not connect to database directly, you should click "Skip this step" on database info entry page

Otherwise you will get this issue. Please try upgrade again and make sure click on "Skip this step".

Additional Information

Secondary Server Configuration