ERROR [cloudgw] Failed to resolve Isengard target. Internal service error with status code 401
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ERROR [cloudgw] Failed to resolve Isengard target. Internal service error with status code 401

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Article ID: 421748

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Updated On:

Products

DX Operational Observability DX SaaS

Issue/Introduction

The below error is reported in apmservices-gateway log many times. 

ERROR 1 --- [cloudgw] [tLoopGroup-4-14] .c.h.HttpIsengardGatewayTransportAdapter : Failed to resolve Isengard target. Internal service error with status code 401 when calling loadbalancer: 401,600,-: UNAUTHORIZED, -.

What does it means and how to solve it please?

Environment

DX O2

Cause

The exception occurs when a bad token in-use by an Agent.

 

Resolution

Identify the problematic Agent and fix the token configuration issue, 

1.- If you are using SaaS: contact Broadcom Support for assistance

2.- If you are using OnPrem:

-Upgrade to dxo2 26.1 and use the apmservices-gateway service log to identify the problematic agent

-If your IT organization is using F5 to mask the agent IP, we are planning to enhance the apmservices-gateway logging further more to identify the problematic Agent. Enhancement # DE650001. Target release 26.2. For an update contact Broadcom Support

Here is an example of the output in the log that will report the problematic agent:

2026-01-16T14:01:53.831Z ERROR 1 --- [cloudgw] [tLoopGroup-4-14] a.c.i.s.IsengardAgentRegisterCallHandler : The agent with an invalid token was registered. [protocol:HTTP, ipAddress:#.#.#.#, hub:Agent_###, agent:<host<|<process-name>|<agent-name>, address:Agent_###.client_main:264]

2026-01-16T14:01:57.492Z ERROR 1 --- [cloudgw] [tLoopGroup-4-18] a.c.i.s.IsengardAgentRegisterCallHandler : The agent with an invalid token was registered. [protocol:HTTP, ipAddress:#.#.#.#, hub:Agent_###,  agent:<host<|<process-name>|<agent-name>, address:Agent_###.client_main:264]]