ERROR "Your Username or password is incorrect" while accessing Aria Automation Config UI using LDAP account
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ERROR "Your Username or password is incorrect" while accessing Aria Automation Config UI using LDAP account

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Article ID: 421719

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Accessing Aria Config UI using the LDAP account fails with "Your Username or password is incorrect".
  • Upon enabling the "EXTENDED" LDAP log level in /etc/raas/raas and restarting RAAS service, the following error appeared in the '/var/log/raas/raas' log.

    [org_id:None][var.lib.raas.unpack._MEIwsMSbn.raas.mods.auth.ldap ][DEBUG   :216 ][Webserver:969862] No DN passed or DN search failed. Running _get_auth_backend_user with this search_filter: (&(objectclass=#####)(sAMAccountName=##########))
    [org_id:None][var.lib.raas.unpack._MEIwsMSbn.raas.mods.auth.ldap ][DEBUG   :216 ][Webserver:969862] Could not find any user using '(&(objectclass=#####)(sAMAccountName=##########))' as the search filter in the ldap backend under the ldap-uat-#### configuration.

Environment

Aria Automation Config 8.x

Cause

This issue occurred as Role-Based Access Control was not enabled for the LDAP users.
Configuring directory services using the LDAP protocol

Resolution

Follow the below steps to resolve this issue:

1. Remove the user from Aria Automation Config UI.

Administration >> Authentication >> Select the LDAP Configuration >> Users.
Select the user >> Click "Delete".

2. Re-validate the LDAP connection in the Aria Automation UI and confirm the user has been rediscovered.
3. Enable the User.


4. Define Role-Based Access Control (RBAC) settings.
5. Re-attempt logging into the Aria Automation UI with the LDAP user.